This article contains troubleshooting and how-to articles related to the Time Off Tracking and Time and Attendance Modules.
Duplicate Clock-In Punches through Employee Portal
Issue
An additional clock-in punch is sometimes generated when employees clock in from the Employee Portal
Cause
Although the clock-in button will gray out once the punch is recorded, it can still respond to commands while it is processing the punch. Variance in internet connection speeds can prolong the period in-which the button remains active.
Resolution
Ensure employees only click the clock-in button once. Advise employees that the button does not require double-clicking to record their clock-in.
Employee Unable to Submit Time
Issue
When signing in to the Employee Portal the employee is unable to clock in/out or submit their time card.
Cause
The most specific cause would be that an entry type has not been assigned and so the system does not know which interface to display for the employee. Confirming the other configuration settings is a best practice.
Resolution
Confirm that all necessary configuration options have been set for that employee. The employee should have a pay schedule and time manager assigned under the employee demographic screen. They also need their Time Entry Type assigned under Settings > Time and Attendance > Settings > Entry Assignments. You should also confirm that a Pay Group has been assigned.
Employees Duplicated in Drop-Down List
Issue
Drop-down fields from manager screens for reviewing time show duplicate employees
Cause
This occurs if a manager is listed as their own manager and the option for Allow Managers to manage employees of downstream Managers is checked in Time and Attendance or Time Off Tracking.
Resolution
Change the manager's listed manager to a selection other than themselves.
Unable to Mark a Time Card as Not Submit/Approved
Issue
Unable to mark previously submit or approved cards as not submit or not approved.
Cause
This will occur when a change has been made to an employee's pay schedule after the card was marked as submit or approved. This could occur because multiple pay schedules are available and the employee has been moved to a new pay schedule since the card was submitted/approved or if the pay schedule the employee is assigned to has been edited since submission or approval.
Resolution
The only way to be able to change the approval/submission status of the card would be to change the pay schedule back to its original state for that employee at the time of submission/approval.
Year Not Populated in Time Off Filter for New Hire
Issue
When reviewing time off for a newly added employee the year filter populates no years in the drop-down.
Cause
The filter is populated based on the presence of time off transactions. If no transactions exist the drop-down will have no years to display.
Resolution
The employee does not have any data to review yet. Once a transaction is created (accrual or otherwise) the filters will populate.
Deleting Time Off Requests
Issue
When deleting an approved time off request, the granted time off transaction is not removed.
Cause
Deleting time off requests are not intended to remove time off transactions. Once the request has been approved a new record is created for the time off transaction, these records are tracked separately in case you need to interact with one but not affect the other.
Resolution
If the intention is to delete the granted time, you would need to navigate to the Time Off Detail tab and delete the time off transaction.
Shift Rule Behavior
Issue
Understanding shift level rules and how they apply to employees within that pay group.
Cause
Shift rounding and promotion rules apply based on the hours the employee clocks in not based on the shift assigned on the Entry Assignments tab. The system will check the time of the employee's punch against the shifts defined within their assigned pay groups in order to determine what rules should be applied to those hours.
Resolution
When applying shift level rules to pay groups make sure that overlapping shifts are split into separate pay groups to ensure that an employee's clocked time does not fall within two shift ranges with potentially varying rules.
Usage Waiting Period
Issue
Usage waiting period field does not restrict employees from requesting time.
Cause
Currently, this field is a place-holder for a function still under review and development. Accrual rules are not referenced when an employee requests time, only when processing the accruals to add time to the designated time off balances.
Resolution
At this time it is up to the time manager assigned to the employee to enforce usage waiting period policies.
Auditing Time Data
Issue
In need of methods to audit or review time data for comparison with exports.
Cause
Often a group will want to compare what was delivered to pay roll against other review methods within the system, as a way of checking that the export is sending at the very least accurate totals.
Resolution
There are a few data review methods available for time data. The dashboard view within the Time and Attendance module will display individual employee totals of regular, overtime and time off hours. This are will also display a total of all employee hours at the bottom of the employee listing. Under the pay period reports tab you can pull one-click reports also containing totals of hours on time cards. Keep in mind both of these methods display data only for employees configured to record worked hours and if time off hours for employees not recording worked hours is needed you will want to access the reports available in time of tracking or configure a custom export through the export utility.
Global Time Off Calendar
Issue
Restricting time off calendar by multiple criteria
Cause
In some cases, a group may want to have the Global Time Off Calendar be filtered or restricted by criteria other than manager/team, such as by department or location.
Resolution
At this time the only options for the time off calendar is to allow visibility into the whole company or limit it to reporting to the same manager.
Carry Forward Date
Issue
Accrual not using specified carried forward date.
Cause
Accrual frequencies referencing the employee hire date will carry forward on the employee's anniversary date, all other frequencies will use the specified date in the accrual rule.
Resolution
This is the intended function. Using another frequency in line with necessary carry forward rules may still meet overall policy needs, if not either a manual adjustment will be necessary or the accruals will need to be calculated externally and imported into the software.
Total Hours Display Discrepancies
Issue
A variance occurs between areas that display total hours, typically the variance is .01 hours.
Cause
Some areas in the system display total hours by presenting the sum of rounded transactions, while others may display a rounded total after summing the exact transactions. While this discrepancy in display does not diminish the accuracy of the values it does cause inquiry when the values do not match.
Resolution
Development is reviewing the areas of the system that display total hours and will come to a decision on unifying at which level the rounding will apply to create consistency in display. Know that the system tracks exact time and this is what will be exported, not the rounded values.
Holiday Worked Hours Promotion
Issue
Understanding holiday worked hours rate promotions.
Cause
Company policy may dictate that employees working on a holiday are entitled to a promoted rate.
Resolution
The pay group can be configured to promote the hours worked on a holiday to a new rate. This feature triggers when rates are being calculated for a transaction, if at this time a system-generated holiday is on the employees time card the transaction will be promoted. You can further configure the pay group to remove the time off that was granted after the promotion occurs. Keep in mind that once the holiday time off is no longer on the card any recalculations of the pay period will return the transaction to the regular rate.
Loading User to Time Clock Stuck
Issue
The function for loading users to the physical time clock does not appear to complete.
Cause
The common cause is that a clock has been registered to the account that is not currently communicating. The function attempts to load users to all registered accounts and will continue to try until successful.
Resolution
The clock that is not communicating can be removed from the account or you can ensure the clock is capable of communicating with the server. If all registered clocks are communicating and the function continues to indicate users are loading you may need to reload your browser to update the indicator. You can confirm the users have been loaded by checking the user count on the clock listing.
Sending Fingerprints to Other Clocks
Issue
Sending enrolled fingerprints out to other clocks registered to the account.
Cause
Enrolled fingerprints are not automatically transferred to the other clocks registered to the account, however, it is not required that you enroll employees at each clock.
Resolution
After enrolling employee fingerprints using one of the registered time clocks, return to the Time and Attendance Settings through the admin portal. Navigate to the Time Clock Config tab and click the link for "Reload Users to all Devices." This will send the newly enrolled fingerprints out to the other devices registered to the account. You can confirm by clicking the user count on each clock and verifying a valid fingerprint is loaded.
Time Card Submit Optional Message
Issue
Unable to access the optional message entered on the submit time card tab.
Cause
The submit time card optional message was added to an email notification that would be sent by the system when submitting time cards in previous version of the module. This email is no longer generated as a courtesy to account with high numbers of direct reports that would find the number of emails generated cumbersome.
Resolution
Disregard this message box and advise employees if they need to add comments to their time cards to do so using the Comments tab. Our development team will be removing this text box to avoid future confusion.
Pay Period Recalc Utility
Issue
Understanding the utility available for recalculating worked-hour transactions.
Cause
The utility may need to be used in order to apply changes in rules to already existing transactions or to correct existing calculations should any issues arise during initial recording.
Resolution
The utility will apply the pay group and shift level rules to transactions. This includes rounding, pay rate assignments/promotions, and auto-meal deductions. Please note that manual adjustments that have been made to these items will be overwritten by the utility.
Controlling Access to Employee Time
Issue
Need ability to assign employees to be capable of being reviewed by managers outside of their direct hierarchy.
Cause
Managers that may oversee specific departments and need to review time cards for all employees that fall under that department regardless of their direct managers. Company needs may not be limited to this example, but still wish to have greater control over who can review employee cards beyond the downstream manager feature.
Resolution
At present time the downstream manager feature is the only option for extending access beyond direct managers unless you wish to grant the user admin access. A feature is currently under development to extend controls over this area.
Locking a Pay Period
Issue
Understanding locked pay period functionality.
Cause
Locking a pay period as an admin in order to prevent further editing of time data. This function is slightly varied from a locked pay period in a payroll system.
Resolution
The software is meant to record data and be a system of record and as such very few situations exist where it will not record or capture data submit to it. Locking a pay period within the software does not prevent data from being loaded using imports or through employee level clock-in/out functions. Locking a pay period will only prevent the editing of transactions through the time cards.
Transaction Level Labor Allocation
Issue
Understanding when there is need to track labor allocation on the transaction level versus demographic levels.
Cause
It is often clear if any level of labor allocation is required, but it is not necessarily clear if these values need to be assigned on the time transaction level or if assigning the values on the employee demographic level will suffice.
Resolution
The determining factor is whether or not the value can vary from day-to-day or even within the same day. If an employee may be assigned to one value for part of a shift or pay period then have another value for other portions of that same shift or pay period, the value will need to be assigned at the transaction level. However, if your employees do not move between these labor allocation values within the pay period it should be sufficient to assign these values on a demographic level.
Pay Rates Not Apply
Issue
Dollar amounts are not appearing on time cards or hours are not appearing in export files because the pay rate is not being applied.
Cause
The common cause of this item is that an overtime rule was overlooked or the employee was not assigned to a pay group. Other configuration items could lead to this issue as well such as not creating pay rates or overlooking assigning the rates to the pay group. If the hours still export in a pay rate based file but do not calculate a dollar amount on the time card it is possible that compensation has not yet been added to the employee's record.
Resolution
This is resolved by confirming the various pay rate related settings. Making sure the rates were created and assigned to the pay group. That all necessary overtime rules have been added to the pay group and that all employees have been assigned a pay group. The alerts tab will indicate any employee not assigned to a pay group or lacking in an overtime rule.
Unable to Select Projects/Cost Centers When Clocking In
Issue
Employee has no option to select cost center or project values when recording time.
Cause
There are two settings levels that must be configured to record projects/cost centers if either are not set up the option will not display for the employee.
Resolution
The general properties tab must be configured to require the desired project/cost center values and the employees need to be configured with the specific values they have access to record time against. The employee assignments are configured through the Projects/Cost Centers Assignments tab found in Time and Attendance. Please note that if you use a hierarchy for cost center values that you are assigning the correct values for each employee.
Auth Types
Issue
Understanding Auth Types on the Entry Assignments tab
Cause
Auth types are used when not recording time through the employee portal.
Resolution
- Card Swipe is used when integrated with the physical time clock but no other entry source. The card number needs to be listed in the Pin field for each employee using proximity cards.Fingerprint Scan is also used only with the physical time clock. Fingerprints are enrolled using the Time Clock Config tab and the physical clock.
- Pin Entry is used for both the physical clock and the stand-alone web clock. When using the physical clock be sure to give the employee their 7 digit ID found on the clock user roster as they will need both the ID and PIN to clock in through the clock. The web clock will only require the PIN, but no ID. Please note that the stand-alone web clock also requires you set up IP restrictions.
- If you are not using the physical time clock or stand-alone web clock you do not need to make a selection for Auth Type.
Shift Assignments
Issue
Understanding the shift assignment on the Entry Assignment Tab
Cause
Needing to know when a shift should be assigned on this tab.
Resolution
The shift assignment will drive the schedule generation utility as well as break/lunch rules set within the shift. All other shift level rules are determined by pay group assignment and actual clocked hours.
Weekly Overtime Calculation
Issue
Understanding how weekly overtime calculations are performed by the system.
Cause
Weekly overtime calculations are needed by all non-exempt employees and it is not determined by pay schedule.
Resolution
Weekly overtime is determined by using the max weekly hours setting on the Overtime Rules tab within each pay group and the week start day specified on the General Settings tab. Since overtime is calculated weekly this calculation gives no consideration to the pay schedules or pay periods you have configured in the system.
Overnight Shift Overtime Behavior
Issue
When an employee clocks out, for lunch or otherwise, in the middle of an overnight shift the second half of the shift is applied to the following day. This can result in inconsistent overtime calculations if you calculate overtime daily or if the shift occurs on the last day of the pay week.
Cause
The system will link transactions with no interruption back to the clock in date, but if an employee clocks out and back in after midnight the system does not know to link this second transaction to previous in/out transaction.
Resolution
At the present time instructing these employees not to clock out is the only way to avoid this system interaction. If needed you can also auto-deduct a set number of minutes for lunch. A resolution to this item is being addressed in the upcoming TLM service pack.
Accrual Based on Date of Eligibility
Issue
Understanding the accrual frequencies that reference eligibility date.
Cause
Could be confused with the demographic eligibility date used for benefits.
Resolution
The accrual eligibility date is calculated by taking the hire date and adding the accrual waiting period days. It does not use the eligibility date that can be specified for benefit eligibility.
Alternate Work Week
Issue
Unable to configure daily overtime for alternate work week configurations (California.)
Cause
The system currently calculates daily overtime with a static daily max configuration, it does not consider the employees expected schedule.
Resolution
Currently, there is no workaround that will accommodate this setup. A feature will be release in the upcoming service pack to allow for this setup.
Dependent Time-Off Types
Issue
Dependent time off types successfully deduct from dependent balance on employee summary page but not when pulling the balance into a report.
Cause
The time off summary was updated with logic to display dependent time off deductions when the dependent time off feature was added. Other reporting areas of the system do not consider this dependency when summing transactions to display a balance.
Resolution
Currently no workaround, development is working to update other areas of the system to account for this dependency.
Time Off Type Eligibility vs. Accrual Eligibility
Issue
Employees loses access to past accrual buckets when eligibility criteria changes
Cause
When eligibility rules are placed on the time off type level when an employee is no longer eligible they no longer are able to interact or see that time off type, regardless of whether they still had accrued time.
Resolution
If employees should maintain these past balances, but just simply stop accruing a certain type or at a certain rate based on eligibility, the eligibility rule should only be placed on the accrual rule not on the time off type itself. Eligibility rules applied to the time off type should only be used if an employee truly will have no interaction with that type.