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Troubleshooting Performance User Import Errors

When using our integration between Core HR and your Talent modules, you may encounter issues where a user import has failed. You can easily resolve some of these errors in either Core HR or your talent modules. Some common performance user import errors have been documented below with solutions or things to look for.

You can also check out our video training on Arcoro Learning.

Table of Contents

Common Errors and Solutions

Unable to Retrieve or Save File

This is commonly due to Core HR or Performance being unable to pick up the file and is typically shown when there is no information to share between the two modules.

For example, if there have been no new hires, terminations, or other demographic changes to employee profiles in Core HR, no file will be generated for import to Performance.

This error is expected and no action is required.

Invalid Location / Location Required

Cause

Commonly due to any of the following:

  • Facility/Location not existing in Core HR or Performance.
  • Facility/Location not active in Core HR or Performance.
  • Facility/Location names do not match exactly in Core HR and Performance.

Solution

  • Make sure that the facility and location exists in both Core HR and Performance.
  • Make sure that the facility and location are active in both Core HR and Performance.
  • Make sure that the facility and location names match exactly in both Core HR and Performance.
    • Same spelling, no spaces, etc.

Invalid Job Code

Cause

Generally due to a job code not matching or existing between Core HR and Performance.

Solution

Make sure that the job code for employees matches in Core HR and Performance.

Invalid Manager / Missing Manager

Cause

Commonly due to any of the following:

  • The employee is not being assigned a manager.
  • The assigned manager is inactive in Core HR/Talent.
  • The assigned manager does not have the manager role in Core HR/Talent.
  • Managers are assigned to each other, causing a manager loop.

Solution

  • Make sure that the employee is assigned a manager.
  • Make sure that the assigned managers are active in Core HR and Talent.
  • Make sure that the assigned managers have the manager role in Core HR and Talent.
  • Make sure that your managers do not report to each other.

Username Duplicate or Required

Cause

Generally due to an employee not having a username or does not have a unique username. Most commonly due to Core HR.

Solution

  • Double-check that the username exists in the appropriate module or does not already exist. 
  • Usernames are unique across all companies and accounts, so two users in separate companies cannot have the same username.

Invalid Department

Cause

The department does not exist in both Core HR and Talent.

Solution

Make sure that the department exists in both Core HR and Talent.

Fatal Error Occurred While Processing Company

Cause

The "System Administrator" user profile is inactive in Performance.

Solution

Make sure the "System Administrator" user profile is active in Performance.

Cannot Insert Duplicate Key Row

Commonly due to an existing user/entitiy existing in Core HR or Performance which prevents the import from the other module.

Please contact us for assistance. 

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